Loading...

Lenovo ThinkPad T Series T420 Speedy Boot Time with Crucial M4 (SSD)

18,769 views

Loading...

Loading...

Loading...

Rating is available when the video has been rented.
This feature is not available right now. Please try again later.
Published on Sep 10, 2011

It takes about 30 seconds from when I press the power on button to when the Windows loading icon stops spinning. This is a clean install of Windows 7 with all Lenovo drivers installed, UEFI boot, AHCI mode and RapidBoot installed. It was installed from a stock copy of Windows 7 and thus does not have Lenovo EE 2.0 installed.

The specs are below but for the HDD being changed to a Crucial M4 64GB SSD. The Windows 7 splash screen has also been removed.

There seems to be quite a delay from when the splash screen finishes loading (indicated in the video by when the screen switches off) to when the Welcome screen loads. If anyone knows how to reduce this delay please post in the comments :).

Processor
Intel® Core™ i5-2540M (2.60Ghz, 3MB L3)

Memory
2X 4GB (up to 8GB DDR3 1333MHz)

Chipset
Mobile Intel® QM67 Express Chipset

Hard Drive
500GB / 7200rpm Hard Drive

Optical Drive
Multi-Burner

Display
14.1" 1600x900 LCD

Graphics
NVIDIA® NVS 4200M Optimus Graphics Technology (1GB VRAM )

Audio
Dual Digital HD MICs

Camera
720p HD Camera

Communication
Intel 802.11agn Wireless, Bluetooth, Modem

Ports
VGA,4 X USB (2 X STANDARD, 1 USB 2.0-Always On, 1 USB/eSATA Combo

Slots
1 Full and 1 Half PCIe

Card Reader
4 in 1

Battery
6 Cell Li-Ion

OS
Microsoft Windows® 7 Professional 64bit

Loading...

When autoplay is enabled, a suggested video will automatically play next.

Up next


to add this to Watch Later

Add to

Loading playlists...