Loading...

[Appium Error Fixed] Error: xcodebuild failed with code 65

840 views

Loading...

Loading...

Transcript

The interactive transcript could not be loaded.

Loading...

Loading...

Rating is available when the video has been rented.
This feature is not available right now. Please try again later.
Published on Oct 1, 2017

Welcome to MobileTesting YouTube Channel

** This is a temporary quick fix, will make a new video with a better fix.

In this video we will resolve the 'xcodebuild failed with code 65' error. Before doing this ensure you are logged into Xcode with your free Apple Developer account.

When we try to run the test cases on a real iPhone device, we get this error 65. It happens because "[Xcode] WebDriverAgentLib has conflicting provisioning settings"

WebDriverAgent Path in Mac:

cd /usr/local/lib/node_modules/appium/node_modules/appium-xcuitest-driver/WebDriverAgent/

Open the WebDriverAgent.xcodeproj in Xcode and search for this "product bundle identifier" in 'Bundle Settings' tab.

Try to change this value "com.facebook.WebDriverAgentLib" to something different.

Choose iPhone in device list and build the project.



The following errors will get fixed:

[XCUITest] xcodebuild exited with code '65' and signal 'null'

[XCUITest] Error: xcodebuild failed with code 65

Error: xcodebuild failed with code 65

[MJSONWP] Encountered internal error running command: Error: xcodebuild failed with code 65

** Ensure you trust the developer in your real iPhone else, the app will get deleted as soon as its installed.


When you run the test case keep an eye on your Mobile screen, the webdriver agent app will be installed and uninstall immediately. I don’t know the reason for this, but what you should do here is as soon as you see the webdriver agent app installed disconnect the cable from mac

Then in iPhone - Settings - General - Profiles & Device Management

webdriver agent will be listed here - tap on it and click ‘Trust’ option. Come to home screen & click on webdriver agent app once, you should see the app opens & a black screen is displayed.

Reconnect the device and rerun your test cases., it should work.

  • Category

  • License

    • Standard YouTube License

Loading...

When autoplay is enabled, a suggested video will automatically play next.

Up next


to add this to Watch Later

Add to

Loading playlists...